Solved

New Logitech Streamcam not working

  • 16 February 2020
  • 3 replies
  • 1411 views

The new Logitech Stream cam is sign by the source list, when I add it, I get a white camera with a slash through it. Is it not supported yet? It’s the new $169 Logitech stream cam and it works on the computer , just not with streamlabs. No other sources of it are open. 

icon

Best answer by SecSeaBeast 31 May 2020, 06:01

Hey all, 

If you are having issues with a Logitech camera, I would suggest uninstalling the Logitech capture software and instead of using Logitech GHUB and see if that helps. Also, make sure your drivers are up to date. 

If you are in need of further assistance, please join us on discord or submit a ticket.

Tickets: https://support.streamlabs.com/hc/en-us/requests/new

Thanks!

View original

This topic has been closed for comments

3 replies

Userlevel 2

Hi, 

Can you make sure you have the Logitech capture software installed and then restart your system? be sure to select the 64 bit version. A setup guide can be found here

If your still having issues after doing this please let me know and I will do my best to troubleshoot this with you. 

If your in our discord server you can shoot me a DM my username is Raichu#0001. 

I just got a Streamcam today and am having no end of trouble with it - it keeps throwing up an error code saying something else is using the device, but when I run a check there are no other apps showing up that are using it...

Userlevel 5

Hey all, 

If you are having issues with a Logitech camera, I would suggest uninstalling the Logitech capture software and instead of using Logitech GHUB and see if that helps. Also, make sure your drivers are up to date. 

If you are in need of further assistance, please join us on discord or submit a ticket.

Tickets: https://support.streamlabs.com/hc/en-us/requests/new

Thanks!