Solved

Macs Crashing

  • 5 April 2020
  • 9 replies
  • 1812 views

Userlevel 1

I’m brand new to OBS and Streamlabs but not to live streaming. Been doing that now for about 15 years on just about every platform, software, and hardware imaginable.

For the past two days I’ve been setting up this software to stream live to all of my social platforms through Restream. It seems like this new Mac software crashes every few minutes, always as I am adding, changing, or removing an element to my OBS scene.

I’ve been running it on 3 different Macs. (#1 Quad core iMac with 32GB of RAM. #2 12 Core Mac Pro with 64GB RAM. #3 Quad Core MacBook Pro with 16GB of RAM)

All are running OS Mojave and are up to date on it. All of them are experiencing the same intermittent crashing while performing the same tasks.

The only piece of add-on hardware that seems to have a problem with this software is a $100 USB 3.0 capture card that I’m using to pull in Skype, Zoom, and WebEx sessions from a laptop PC. Other than that every flavor of Blackmagic capture device or card that I use is mostly playing well with Streamlabs OBS. The crashing was happening before I added the USB capture card. SO, I know that’s not the issue.

I’m not having these issues with the open source version of OBS. So, it’s got to be this new Streamlabs software. With all of the add-ons and the potential that this version of OBS has, I’d really like to stick with it. Just need to find out what may be causing all of the crashing.

Can you help? Thanks!

 

icon

Best answer by SecSeaBeast 31 May 2020, 05:44

Hey all, 

The Streamlabs team is working on improvements. Thanks for all your reports!

If you are in need of further assistance, please join us on discord or submit a ticket.

Tickets: https://support.streamlabs.com/hc/en-us/requests/new

Thanks!

View original

This topic has been closed for comments

9 replies

Streamlabs also constantly crashing for me. On MacOS 10.15.4 Catalina. Quad-core i7, 8GB RAM.

Me too. Especially if I go to edit an NDI source to try and fix the extreme audio to video lag I’m getting from and Elgato HD60 S. Every time, not just sometimes. EVERY time. I can also get more out of OBS before crash. But I want the feature set SL offers.

 

Please help. I’f followed every link I can find to upgrade individual components.

 

MacOS Catalina v10.15.4

Hi,

I’ve just been through all the possible upgrades again and gone to NDI for tools and drivers.
https://www.ndi.tv/tools/ the link has Mac drivers and tools down at the bottom.

I’ve installed them all and can actually press on a source button without SLOBS crashing. *** edit: it’s just crashed again.*** It also solved the ridiculous timing issues I had between audio and sound. It’s now perfect. *** the timing issues is still fixed. ***

Hope that helps.

Holly

x

The Mac app is crashing for me as well. Every time I try to install or change a theme it freezes and then says there was an error.
2.4Ghz i5
16GB RAM
10.13.6

I realize that SLOBS for Mac is supposed to be in Beta right now, but it’s not even Alpha quality,  It’s just plain awful.

 

  • It crashes randomly when I try to add to a scene.
  • It hangs randomly when I try to add to a scene or switch scenes.
  • When you tell it to import from OBS, it just sits there and spins.
  • I randomly get this message that something happened but I’m still streaming. I didn’t even start a stream, so what the hell is it even talking about?  Clicking NO crashes it.  Clicking YES gives another message and hangs it.

    This error sometimes will come up after every other anything I try to do.

  • It doesn’t invoke prompts to ask for all of the permissions it needs, only the camera, mic, and screen recording.  A couple of others sit in your Privacy & Security settings unchecked without you even knowing it until you happen to come across it.

     

  • Audio input sources will sometimes pick up on each other, duplicating audio output.
  • When it hangs or crashes, nine times out of ten it loses recent changes made to scenes.

 

Right now this app is such a hot mess I don’t even want to start streaming on it. I’m afraid it’ll crash or hang while I stream, causing unnecessary disruptions, possibly messing up my stream, and create a disappointed viewer base that will end up as frustrated as I would be.

Streamlabs, I know you’re trying, but you really needed to put more work into this before releasing it to the public even as a Beta. These are Alpha stage problems.  Seriously, what an incredibly frustrating first impression and a total waste of an evening.

 

Having the same issue. Happens after I tinker with some settings. 

 

 

I realize that SLOBS for Mac is supposed to be in Beta right now, but it’s not even Alpha quality,  It’s just plain awful.

 

It crashes randomly when I try to add to a scene.

  • It hangs randomly when I try to add to a scene or switch scenes.
  • When you tell it to import from OBS, it just sits there and spins.
  • I randomly get this message that something happened but I’m still streaming. I didn’t even start a stream, so what the hell is it even talking about?  Clicking NO crashes it.  Clicking YES gives another message and hangs it.

Right now this app is such a hot mess I don’t even want to start streaming on it. I’m afraid it’ll crash or hang while I stream, causing unnecessary disruptions, possibly messing up my stream, and create a disappointed viewer base that will end up as frustrated as I would be.

Streamlabs, I know you’re trying, but you really needed to put more work into this before releasing it to the public even as a Beta. These are Alpha stage problems.  Seriously, what an incredibly frustrating first impression and a total waste of an evening.

 

I feel exactly the same, I know they are still fixing up the systems and what not. But before I found out the problems, I subbed to Prime for a month. Lucky was just a month. Now I feel like a dodged a bullet at not getting the year of it!

I have a MacBook Air 2017, dual core 1.8 i5 (uses between 30-50% so CPU is fine). Then I got a memory Diag app to see where my 8GB DDR3 RAM is going. It seems like the app is using between 2-3GB. Now when I use other streaming apps the memory is up to 75% used and the stream and/or recording is stable.

With SL OBS it isn’t even stable before you stream. And that is simply gamebreaking.

Wow this is my experience too.  Spinning wheel on import attempt.  Yet constant crashes when rebuilding my show one scene at a time.  Just wish I had read this post before trying to migrate my whole giant show over from OBS studio to Streamlabs OBS.  Oh well.  OBS Studio wasn’t that bad.  Glad I didn’t pay for Streamlabs prime or I’d be super pissed.

Userlevel 5

Hey all, 

The Streamlabs team is working on improvements. Thanks for all your reports!

If you are in need of further assistance, please join us on discord or submit a ticket.

Tickets: https://support.streamlabs.com/hc/en-us/requests/new

Thanks!