Solved

Crashing while streaming Cod MW(2019)

  • 10 January 2020
  • 24 replies
  • 2904 views

We as a Team of 3 can´t stream Call of Duty. For myself i got the Driver Error with an fresh new Pc and freshly installed Drivers. (Rtx 2070 Super, 16 Gb Ram, Ryzen 1800x)

And my partners getting game Crashes while streaming with SLOBS.

 

I tried everything old Nvenc, New, game Capture Fullscreen, Window Captures and so on. i cant stream it without getting errors in SLOBS. is there any solution? And do u need more Informations?!

icon

Best answer by jat0rz 11 January 2020, 21:57

Hey again,


I do apologize for not seeing this information.  If you continue to respond disrespectfully though, your post will be removed.

Try to remember we are trying to assist you.

I am able to stream COD using OBS Studio and Streamlabs OBS, both with no issue.  The problem is that this game causes issues for specifics setups.  It does not affect everyone.

It is not specifically a SLOBS problem as I have also seen reports of OBS Studio having the same issue.  I will relay your report to the devs and see what I can do from there.

View original

This topic has been closed for comments

24 replies

Userlevel 6

Sorry to hear this @KaJiRoTV !

 

The solutions in this guide here should help you resolve this issue:

https://howto.streamlabs.com/streamlabs-obs-19/crash-on-streamlabs-obs-something-went-wrong-what-happened-and-how-to-fix-this-84

 

Please try each step, in order and let us know the outcome!

Nope these Solution doesn´t work. If any solution here would work i wouldn´t make a new thread thanks and as for  the threads i found Cod MW has problems for Month. Atleast is it on ur side or on InfinityWards side? I mean i got Crashes with x264, Nvenc old, Nvenc new.

 

But i need to beg for pardon it is not that the SLOBS Software crashes it is that the stream itself crashes i get ther driver error ( yeah fully clean insttaled them) or the game wich crashes after a fricking long slow down. it is not that it helped me to disable any overlay or playing in window, low settings dont change anything. after a random cycle of time i got an stream crash with mentioned problems

Userlevel 4

Hey there,

Can you try turning off your NVIDIA highlights and see if this resolves your issue?

Hey there,

Can you try turning off your NVIDIA highlights and see if this resolves your issue?

It wasn´t enabled.

 

For the record i tried the overlay solution, the solution with differend captures, used differend codecs, used differend sample rates, freshly reinstalled the nvidia driver, tryed it with CoD on normal priority, with SLOBS on Higher as above and Highest priority, dis and enabled windows gamemode, tried it with only one connected screen and so on. after a cycle of time SLOBS got the driver error or CoD slows down from 120+ fps to 15. ah and i tried it from low to high settings in CoD.

still the same error and it is only if i want to stream CoD. everything else works wonderfull, from Destiny 2 over Division 2 over Code Vein and Battlefield only CoD is a piece of junk 

Userlevel 5

Hi there @KaJiRoTV!

Have you tried using a game capture with capture any fullscreen application instead of capture specific window?

I am aware that my english isn´t the best but i think i clear it out that i tried “the solution with differend captures” wich for me means captur fullscreen application, specific window and so on. i tried every solution i  found on this forum…. as i said before...

Userlevel 7

Hey there,

Unfortunately, we cannot see the solutions you have tried/did not try, which is why we need to troubleshoot with you, and may sometimes ask you to do something you have already done.

Since the issue is specifically with one game, the latest COD, it is difficult to find the fault in the software.  We have had reports of COD causing errors and it is being looked into.

Out of curiosity, what GPU and CPU do you have?  I know you said you tried both encoders, but I am curious about your specific hardware.

The issue, again, is not specifically Streamlabs, and it definitely has something to do with COD as well.

So if u all could read i already said all specific solutions i tried! So no need to tell me the whole solutions i already discribed so read before u answer thanks. and unfurtunate for ur software with normale OBS i got not a single problem, i streamed CoD with OBS for over 4 Hours without problems and the problems i got with SLOBS are on this Forum since release so it is a SLOBS Problem and not mine. maybe it is something with SLOBS and CoD but it definitly is a SLOBS problem! So once and for all i would apriciate to use SLOBS further but is there any Fix for this fricking Driver Error or not!? And oplz dont come with freshly clean nvidia driver install. i did it without any succes.

 

 

“Out of curiosity, what GPU and CPU do you have? “ u rlly dont read the threads right? RTX 2070 super, amd Ryzen 1800x with 16gb Ram 

Userlevel 7

Hey again,


I do apologize for not seeing this information.  If you continue to respond disrespectfully though, your post will be removed.

Try to remember we are trying to assist you.

I am able to stream COD using OBS Studio and Streamlabs OBS, both with no issue.  The problem is that this game causes issues for specifics setups.  It does not affect everyone.

It is not specifically a SLOBS problem as I have also seen reports of OBS Studio having the same issue.  I will relay your report to the devs and see what I can do from there.

So i am disrespectfull? cause i am sarcastic and pissed. first of all i provided all information i could, than i apologize for a mistake i did at the creation of this thread to not clearify what i meant. than i provided every information ive got, every solution i tested and i asked if any more information was needed. all i got was solutions i said i did before. so u earn ur money with this i do it with streaming u see if u chew the same of the same of the same over and over again it is annoying and time wasting. i hope u understand that u as the third came the wrong time with something i allready posted. 

 

u said it is not a SLOBS problem ok than plz tell me i honestly asking cause i want to understand it why i can stream with OBS w/o any problems?! Isnt SLOBS using much of the same resources than obs?  Is there not any fix, tweak or anything i can do to avoid this? (Dirver Error to clearify) i mean if it would be only an NVENC problem but it is also x264 problem at SLOBS.

 

and could u tell why my partner (1070 ti, ryzen 2700x, 16gb ram) has also problems with only SLOBS if it is not a SLOBS problem? 

 

Ah if u need the exactly products i am running plz let me know. i´ll provide as much information as i can.

So i am disrespectfull? cause i am sarcastic and pissed. first of all i provided all information i could, than i apologize for a mistake i did at the creation of this thread to not clearify what i meant. than i provided every information ive got, every solution i tested and i asked if any more information was needed. all i got was solutions i said i did before. so u earn ur money with this i do it with streaming u see if u chew the same of the same of the same over and over again it is annoying and time wasting. i hope u understand that u as the third came the wrong time with something i allready posted. 

 

u said it is not a SLOBS problem ok than plz tell me i honestly asking cause i want to understand it why i can stream with OBS w/o any problems?! Isnt SLOBS using much of the same resources than obs?  Is there not any fix, tweak or anything i can do to avoid this? (Dirver Error to clearify) i mean if it would be only an NVENC problem but it is also x264 problem at SLOBS.

 

and could u tell why my partner (1070 ti, ryzen 2700x, 16gb ram) has also problems with only SLOBS if it is not a SLOBS problem? 

 

Ah if u need the exactly products i am running plz let me know. i´ll provide as much information as i can.

I have similar problems to you. Tried all the troubleshooting things they recommended. I have a 3700x, I have a feeling that the Ryzens may be not as supported with SLOBS.

Userlevel 6

Hey there, I know you mentioned trying low settings in the game but have you tried to disable ray tracing and anti aliasing as this usually help with this issue.

Like that yeah i did this. Tried it as i said, without anti aliasing and without Ray tracing. Beside that u cant play this game without atleast anti alaiasing cause it looks like shit i did not help at all. 

I even tried it with turned off SSR like i read it as a solution here at the forum.

 

oh and i want to clearify i can stream CoD but AFTER a non estimated time i get the Driver error.  i want to mention that the system before hand was totally clean installed and after the first time error i did the driver clean install solution without any success

Seems to be a latest problem with Ryzen cards - it’s unfortunate. I can’t see it being a problem with your GPU as a friend streams with the same GPU no problem, just the GPU is different. I am also hunting for an answer, but they keep telling me the same thing and it isn’t working. I have tried EVERYTHING on their list.

Yeah i tried also Everything but as u read its always the same… but i am curious why i got no problems with OBS and why a friend of mine with another setup GTX 1070 Ti, Ryzen 2700x got the same problem as me with an RTX 2070 super, ryzen 1800x

I have a feeling it might be the CPU with RAM issue. But I have 16GB RAM, and a very good CPU. My CPU should be fine to stream with, in fact it is recommended a lot. So I have no idea too. Let’s hope they can provide us with a solution.

what do you mean with “cpu with Ram issuee”? 

 

As long as i am aware there is not a issue if u got your set up right. 

Apparently, AMD processors can mess with the RAM a little. My set up hasn’t been messed with, it should work. By what I can see, it seems to be issues with AMD processors mostly.

to be honest doesnt sound legit to me. if it would be such a problem u should have it more often and dont only if u stream with SLOBS as i said try OBS or Shadowplay and u can stream without any problem. if it would be an “amd issue” we should have more problems than only at streamin with SLOBS

Streamed today 3 hours, OBS Studio. No issue.

like i said but with SLOBS u got this “Driver error” but as we can read it isnt an SLOBS issue.. know what i mean? Other Streaming Programms dont got the problem at me but SLOBS.

So still no Fix, walkaround, tweak? Any Updates?

Userlevel 7

Hey again!

Unfortunately, not at this time.  As I had mentioned earlier, this issue is ongoing and affects both versions of the software.  It is specific to COD and specific hardware setups.